240sxONE Forums

Go Back   240sxONE Forums > 240sxONE Tech and Style > Electrical Tech

Reply
 
Thread Tools
  #1  
Old 10-18-2014, 07:39 PM
RBRUCE762 RBRUCE762 is offline
240sxONE Member
Real Name: Rich
 
Join Date: Oct 2012
Location: Norwich
Posts: 112
Default circuit sports fan controller? any one else running?

any one else running the cs fan controller?
(on a stock sr except for oil catch tank, walbro, stock ecu, and a battery relocation kit, wiring specialties main and trans harness)

here is my issue, car runs fine at idle, until fans kick on, as soon as fans kick on, my charging system drops between 12-12.4 volts. when the fans are off, im running 13.8-14.

they are clearly drawing too much power, but i dont understand how, just want to see if any one else is having the issue, im running no stereo, only other pieces i have power wired to is my gauges
just wondering if i have something wired to the wrong spot, i figured if it was a ground issue, i wouldnt draw as much power (am i wrong? not being able to close the circuit as well with a crappy ground)

any input or ideas to help figure this our would be great.
Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 10:58 AM.


Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
2008 - 2010 Aurobius LLC