240sxONE Forums

Go Back   240sxONE Forums > 240sxONE Tech and Style > Electrical Tech

Reply
 
Thread Tools
  #1  
Old 06-17-2014, 09:36 PM
DVasky DVasky is offline
240sxONE Member
Real Name: Davis
 
Join Date: Jun 2013
Location: Pembroke
Posts: 22
Default No Dash backlight, no speedo, no brake/taillights?

I have tach, and everything else besides the speedo working, and the headlights work but the dash backlight doesn't, and neither do my tail/brakelight. Anyone have any suggestions?
Reply With Quote
  #2  
Old 06-18-2014, 07:26 AM
twistedsymphony's Avatar
twistedsymphony twistedsymphony is offline
your manager of serious internet business
Real Name: Mike
 
Join Date: May 2005
Location: Tilton, NH
Posts: 10,692
Default Re: No Dash backlight, no speedo, no brake/taillights?

I believe the taillights and dashlights are on the same fuse so replace that first (don't go by looks, actually test it or just replace it)

if that doesn't work or the fuse keeps blowing check to make sure your front tire hasn't worn through the fender liner and started chewing up the harness.
__________________
Every job is a self-portrait of the person who did it... Autograph your work with excellence.

SilviaV8 Forums | CollectorsEdition.org | My Blog | My Build Thread | My For Sale Thread
Reply With Quote
Reply

Tags
backlight, cluster, gauge, lighting, taillight

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:11 AM.


Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
2008 - 2010 Aurobius LLC