240sxONE Forums

Go Back   240sxONE Forums > 240sxONE Tech and Style > Build Threads and Project Logs

Reply
 
Thread Tools
  #71  
Old 07-05-2016, 07:26 PM
RedEvil RedEvil is offline
240sxONE Member
Real Name: Red. Evil.
 
Join Date: Sep 2004
Location: Cybertron.
Posts: 2,414
Send a message via AIM to RedEvil Send a message via MSN to RedEvil
Default Re: Wild Steves KA-T Coupe Build

Well done! Someone may whine you ruined bricks, but who cares?
__________________
Reply With Quote
  #72  
Old 07-05-2016, 10:24 PM
chubbs chubbs is offline
240sxONE Member
Real Name: Wild Steve
 
Join Date: Dec 2012
Location: Southwick, Ma.
Posts: 387
Default Re: Wild Steves KA-T Coupe Build

Anybody who complains that I ruined bricks has never ran them, or doesn't drive at night. It was literally so miserable.

I have a spare set in my garage, and if my homie doesn't buy em, i'll ruin those ones too.
__________________
Reply With Quote
  #73  
Old 07-06-2016, 09:38 PM
RedEvil RedEvil is offline
240sxONE Member
Real Name: Red. Evil.
 
Join Date: Sep 2004
Location: Cybertron.
Posts: 2,414
Send a message via AIM to RedEvil Send a message via MSN to RedEvil
Default Re: Wild Steves KA-T Coupe Build

Exactly. I never got the point of looks over being able to see at night.
__________________
Reply With Quote
  #74  
Old 08-03-2016, 11:29 PM
chubbs chubbs is offline
240sxONE Member
Real Name: Wild Steve
 
Join Date: Dec 2012
Location: Southwick, Ma.
Posts: 387
Default Re: Wild Steves KA-T Coupe Build

Nothing to crazy going on lately. My speedhut gauges came in today. Cut apart a 180sx cluster I had laying around, and used a cutting board to make a backing plate. Travis help me plot and drill the holes. Painted it back, re-assembled and epoxied the 3 pieces together. Dropped my gauges in for a picture.



Aside from that. I have a front lip coming for my aero bumper tomorrow. I'll be sending it off to paint tomorrow night.

Edit: Wired up and installed my gauges last night. Everything works except the high beam indicator (because of my retrofit)
Couple crappy shots, i'll get some better ones in the next few days.


__________________

Last edited by chubbs; 08-08-2016 at 03:11 PM.
Reply With Quote
  #75  
Old 08-12-2016, 08:07 PM
chubbs chubbs is offline
240sxONE Member
Real Name: Wild Steve
 
Join Date: Dec 2012
Location: Southwick, Ma.
Posts: 387
Default Re: Wild Steves KA-T Coupe Build

Stopped by my body guys house the other day, he's got some fiberglassin together for me then I gotta make sure fitment is good then have him paint it for me...

In the mean time, got some LED boards and made my tail lights more awesomer.

__________________
Reply With Quote
  #76  
Old 08-13-2016, 02:02 PM
RedEvil RedEvil is offline
240sxONE Member
Real Name: Red. Evil.
 
Join Date: Sep 2004
Location: Cybertron.
Posts: 2,414
Send a message via AIM to RedEvil Send a message via MSN to RedEvil
Default Re: Wild Steves KA-T Coupe Build

Not too shabby!
__________________
Reply With Quote
  #77  
Old 09-02-2016, 10:21 AM
chubbs chubbs is offline
240sxONE Member
Real Name: Wild Steve
 
Join Date: Dec 2012
Location: Southwick, Ma.
Posts: 387
Default Re: Wild Steves KA-T Coupe Build

After some fighting with these once or twice before, Travis stopped by last night and we got the car to run on the LS2 coils. Hopefully do some tuning this weekend

__________________
Reply With Quote
  #78  
Old 09-21-2016, 08:15 PM
chubbs chubbs is offline
240sxONE Member
Real Name: Wild Steve
 
Join Date: Dec 2012
Location: Southwick, Ma.
Posts: 387
Default Re: Wild Steves KA-T Coupe Build

Installed my LS2 coils, and spare valve cover tapped for 3/8" NPT and -8AN line for my catch can. PCV also goes to catch can.




And a rolling shot, because those are the best car photos.
__________________
Reply With Quote
  #79  
Old 10-01-2016, 01:06 PM
chubbs chubbs is offline
240sxONE Member
Real Name: Wild Steve
 
Join Date: Dec 2012
Location: Southwick, Ma.
Posts: 387
Default Re: Wild Steves KA-T Coupe Build

Started my car thursday morning to go to work and turned on the defroster, and it didn't smell great. Checked my coolant, and it was super low. My heat has always sucked, so i'm assuming its time for a heater core. What a fun project.

Since the OEM nissan ones are $200 and discontinued, I was forced to buy a Spectra one from Autozone. Says it fits 90, so I buy it. Get it home and take the old one out. No dice. The 89/90 inlets/outlets have tabs that hold them in, and the 91-94 (which I found out later) has ones that screw in like the Spectra one. Luckily I had a friend with one sitting around and he gave it to me to use the inlet/outlet pipes. I knew the OEM nissan part numbers were different, but I didn't know the actual difference. Since nobody runs heat in these turds...the internet couldn't tell me either.

anyways:



Previous to the loss of coolant, my heat never worked great, I would just be mean to the car until I got the notorious s13 trans tunnel heat. Gonna go on a limb and say this AC condensor between the blower motor and the heater core may have something to do with it. I removed it, cut the pipes for the AC so I don't have ugly holes in my wire wall, and put it back.
__________________
Reply With Quote
  #80  
Old 10-16-2016, 10:13 AM
chubbs chubbs is offline
240sxONE Member
Real Name: Wild Steve
 
Join Date: Dec 2012
Location: Southwick, Ma.
Posts: 387
Default Re: Wild Steves KA-T Coupe Build

To be continued...

__________________
Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:00 PM.


Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
2008 - 2010 Aurobius LLC