240sxONE Forums

Go Back   240sxONE Forums > 240sxONE Tech and Style > Engine and Drive-line Tech

Reply
 
Thread Tools
  #1  
Old 04-27-2015, 08:07 AM
spineshankzx's Avatar
spineshankzx spineshankzx is offline
240sxONE Member
Real Name: Rick
 
Join Date: Aug 2010
Location: Virginia
Posts: 700
Default Progressively Richer Idle/Leans out at Top

Salutations,

So my car has been running very strange over the past 7 months of driving. I'm switching to Nismotronic and i don't want to go to the tuner and realize there is a larger issue than just needing a re-tune because to me, it sounds like something is going bad.

Timeline:

Tuned and ran great

Swapped stock intake plenum to Isis (freddy) maybe 8 months after

~ 3 months later I noticed once my car idled for around 10 - 15 seconds it would go from 14.7 - low 13's high 12's, pressing the gas would rev and hold at 14.7 again and repeat symptoms.

Now, it's Richer (10's - 12's at idle) and Wthere isn't any wait it's just straight to 10's - 12's once car is stopped AND after 5k RPMs (under 11lbs Boost) it leans out to 16s and 17s.

My concern (maybe i'm just being a bitch) is that the Intake plenum upgrade isn't the issue and when i go tune, it's something else.

Mods:
AFPR - Circuit Sport
Walbro
Z32 maf
550cc injectors (Stock rail)
Isis Intake Manifold
Nistune
S15 Turbo (11lbs, exactly what it's tuned for)
Megan Tubular manifold/Elbow/Downpipe
CatCo Hi-Flow Cat
FMIC
XRP 20 micron filter

Troubleshooting done:

Checked all Couplers
Plugged in nistune and ran some logs and nothing looks bad
Injector Duty doesn't go past 60%
Swapped z32 Maf with a different one
Re-wired Fuel pump relay because the connector was cracked, re-pinned the AC Con fan connector. (not the relay, just the relay input connector)
Calibrated Wideband

I've ordered a new Tomei FPR in hopes to provide an upgrade over Circuit Sport and also thinking that there is something wrong with the CS-AFPR.

The Walbro doesn't have too much life on it, maybe 25k miles over 5 years. If that is alot, then i'll replace that as well. I
__________________

Last edited by spineshankzx; 04-28-2015 at 07:24 AM.
Reply With Quote
  #2  
Old 05-03-2015, 06:18 AM
spineshankzx's Avatar
spineshankzx spineshankzx is offline
240sxONE Member
Real Name: Rick
 
Join Date: Aug 2010
Location: Virginia
Posts: 700
Default Re: Progressively Richer Idle/Leans out at Top

Update:

Since i've done exhaust work on the car recently, It occured to me that the Cat could be on backwards.

I took it off, ran open Downpipe and had the same rich ass idle as before. Put the cat back on the correct way and re-calibrated the wideband and sensor once more.

I also replaced the CC AFPR with a Tomei Type S. Same issues are present. At this point I don't quite know what to do. I've emailed my Tuner and sent in the logs and he said it's all good and this is just a symptom of an Untuned Intake Manifold install.

Re-tune should fix this.
__________________
Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:36 PM.


Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
2008 - 2010 Aurobius LLC